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Written, designed and developed by Chris Converse

Moving your design with Flash®

Introduction
Recent impovements in Adobe Flash CS3 Professional 
include the ability to import Adobe Photoshop® (PSD) 
and Adobe Illustrator® (AI) files, while preserving layers 
and structure, and then edit them. Artwork and designs 
that you spent time perfecting in Photoshop or Illustrator 
can now be exported to Flash ready to be animated and 
included in interactive experiences.

Improved wizards in Flash CS3 Professional make it easier 
to create a video player for your website. Add the new 
video editing capabilities available in Photoshop CS3 
Extended, and the ability to deliver your designs in 
interactive and motion based media is within reach.

Open the Attachments Panel.
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Moving your design with Flash®

Setting up a destination for your web files
Create two folders on your Desktop, one named myAdvertisement and the second named myVideo. These will be the locations where we save our web 
pages, videos, and files created n Flash.

Creating an interactive, animated advertisement
In Illustrator, open aquathon.ai from the assets provided in the Attachments Panel of this PDF document.

Assets
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Moving your design with Flash®

Creating and editing Symbols in Illustrator

Open the Symbols and Layers panels from the Window menu.

Symbols panel in Illustrator

Layers panel in Illustrator
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Moving your design with Flash®

Select the droplet shape using the Selection tool, then drag the object into the Symbols panel. Name the symbol “droplet” in the 
Symbol Options dialog box. Click OK.

Droplet artwork
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Moving your design with Flash®

Drag out copies of the droplet symbol onto the layout. Scale and rotate the droplets to different positions on the layout.

Illustrator document
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Moving your design with Flash®

Double-click one of the droplet symbols on the layout to enter isolation mode. Set the blending mode to Hard Light and the Opacity to 
30% in the Transparency panel. When finished, click the left arrow in the object path represented at the top of the Illustrator document to 
exit isolation mode.

Illustrator document 
Symbol isolation mode

Object path

Click to return to 
main layout (exit 
isolation mode).
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Moving your design with Flash®

Save the finished ad to the myAdvertisement folder on your Desktop as aquothon_ad.ai.

Finished Illustrator document
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Moving your design with Flash®

Making a New Flash Document

Start the Adobe Flash CS3 Professional software. From the splash screen (or choose File > New), choose new Flash File (ActionScript 3.0) document.

Splash screen in Flash

Choose Flash File (ActioScript 3.0)

New Flash (.fla) document
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Moving your design with Flash®

Importing Illustrator into Flash

Drag the native Illustrator document directly onto the stage in your Flash document. (You can also choose File > Import > Import to Stage).

Flash (.fla) document
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Moving your design with Flash®

All artwork and layers will be displayed in the Import to Stage dialog box in Flash. Select each layer and choose Create movie clip from the options 
on the right-hand side. In addition, make sure the Place objects at original position and Set stage size as Illustrator artboard/crop area op-
tions are selected.

Click OK.

Close up the object listing 
for each layer using the 

toggle arrow.

Select the Create movie 
clip option for each layer.
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Moving your design with Flash®

Once the import is finished, you will notice the Library panel has new artwork and Symbols in it, the Stage and Timeline have the layers and artwork 
properly positioned, and the Properties panel shows the Stage size has been set to match the original Illustrator file.

The converted bitmap 
artwork is placed into a 

movie clip…

…which is then placed 
on the stage to match the 

original layout from Illustrator.

Stage size set to match 
artboard from Illustrator.

Layers are 
created to 
match the 
layers from 
Illustrator
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Moving your design with Flash®

Click and drag downward from the 70th frame of the title layer to the 70th frame on every layer.

Timeline in Flash

To select the 70th frame 
of all layers, click on 
frame 70 in the top-most 
layer, keep the mouse 
button pressed, and 
drag downward to the 
last layer.

This should be done as 
one smooth motion… 
click and drag downward 
to select that frame in all 
layers.
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Moving your design with Flash®

Creating an Animation in Flash
Choose Insert > Timeline > Keyframe. This will create a duration for each layer of 70 frames. Notice the initial keyframes for each layer are still located 
at frame 1.

Timeline in Flash

Keyframe indicator
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Moving your design with Flash®

Animating (tweening) the background shapes

Using the same method as page 13, select the first frame in each layer except orange box and blue box. Release the mouse for a second, then click-
and-drag any of the first selected frames and drag it to frame 40. This will drag all of the first selected frame’s keyframes to frame 40.

Flash will automatically create blank keyframes for each layer indicating that those layers will not be visible for the first 40 frames.

Timeline in Flash

Timeline in Flash

Blank keyframe indicator

Moved keyframes
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Moving your design with Flash®

Select the 25th frame of the orange box layer and choose Insert > Timeline > keyframe. Move the timeline jogger to the first frame, select the orange 
box artwork on the stage, and move the box off of the stage to the right.

Timeline jogger
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Moving your design with Flash®

Select any frame(s) in between the first and second keyframes in the orange box layer, choose Insert > Timeline > Insert Motion Tween.

Select any frame 
inbetween the two 

keyframes, then 
choose Motion from 

the Tween menu in 
the Properties panel

NOTE:  Tweening
This is a term used in Flash 
to explain the “in-between” 
frames of an animation.

When two keyframes have 
different properties, such 
as position, creating a Mo-
tion Tween between the 
keyframes triggers Flash to 
create each intermediate 
frame needed to create the 
animated effect.
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Moving your design with Flash®

Select the 35th frame of the blue box layer and add a keyframe. Move the timeline jogger to frame 1 and select the blue box artwork on the stage. 
Move the blue box artwork off the stage to the left.

Select any frame(s) in between the first and second keyframes in the orange box layer, choose Insert > Timeline > Insert Motion Tween.

Select any frame inbetween the 
two keyframes, then choose 

Motion from the Tween menu in 
the Properties panel
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Moving your design with Flash®

Animating (tweening) the photos

Select the first keyframes for each of the janet and christina layers and drag them back to the 15th frame. Create an additional keyframe on each layer 
on the 40th frame.

Select first keyframes

Move keyframes to frame 15

Create new keyframes at 
frame 40 for each layer
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Moving your design with Flash®

Move the timeline jogger to frame 15, then select the christina artwork on the stage. Move the christina photo off the stage to the left and create a 
motion tween between the first two keyframes on the christina layer.

Move the timeline jogger to frame 15, then select the janet artwork on the stage. Move the janet photo off the stage to the right and create a motion 
tween between the first two keyframes on the janet layer.

Create a motion tween
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Moving your design with Flash®

Move the first keyframe for the drops layer to frame 1. Create a second keyframe at frame 19.

Move keyframe to frame 1

Create a new keyframe at frame 19
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Moving your design with Flash®

Move the timeline jogger back to frame 1 and select the drops artwork on the stage. 
In the properties panel, set the Color to Alpha and the value to 0%.

properties panel 
in Flash
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Moving your design with Flash®

Animating (tweening) the Titles, Dates and Location text

Select and move the first keyframes for the title and sub title layers and move them to frame 28. Create an additional keyframe on each layer at frame 
43. Move the timeline jogger back to frame 28.

Select the title artwork on the stage and move it upward and off the stage. Select the sub title artwork on the stage and set the Color to Alpha at 0%. 
Create a motion tween between the first two keyframes on each of the title and sub title layers.
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Moving your design with Flash®

Select and move the first keyframes for the date and whistler layers and move them to frame 40. Create an additional keyframe on each layer at frame 
55. Move the timeline jogger back to frame 40.

Select the date artwork on the stage and move it off the stage to the right. Select the whistler artwork on the stage and move it off the stage to the 
left. Create a motion tween between the first two keyframes on each of the date and whistler layers.

Save the file as promo_ad.fla into the myAdvertisement 
folder on your Desktop.

Save the file

NOTE:  Flash File Formats

 
FLA: This is the source 
Flash file. It contains the 
Library, ActionScript, and 
timeline settings needed 
to create a SWF file.

 
SWF: This is the file pub-
lished from the FLA file 
that is suitable for post-
ing on your website.
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Moving your design with Flash®

Stopping the Animation
Once our animation plays through, we’ll want it to stop at the end. In order to do this we need to add a very small piece of ActionScript. Create a new 
layer in the timeline and name it script. Select the 68th frame of the script layer and choose Insert > Timeline > Blank Keyframe. Open the Actions 
panel from the window menu and type in  stop();

Layers panel

Selected blank keyframe with an 
action assigned to the frame

The ActionScript assigned 
to frame 70
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Moving your design with Flash®

Testing/Previewing Your Animation
To test your progress, choose Test Movie from the Control menu. This will publish a .swf file and preview directly in Flash. Watch the animation and 
note how the animation stops at the end.

Preview of SWF file.
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Moving your design with Flash®

Adding Interactivity with Components
Make a new layer named button and add a blank keyframe at frame 50 (Insert > Timeline > Blank Keyframe). Select frame 50 on the button layer and 
open the Components Panel from the Window menu. Create a blank keyframe at frame 50 and drag the Button component from the User Interface 
set onto the stage over the blue area under Christina’s photo.

NOTE:  Components
Components are 
compiled MovieClips 
that have artwork and 
ActionScript already set 
up and programmed 
for you. All you need to 
do is drag-n-drop them 
onto your stage.

Once on the stage, you 
can customize them 
with the Component 
Inspector panel, or 
double-click them to 
enter isolation mode 
and modify the artwork.

Layers panel

Timeline

Stage
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Moving your design with Flash®

The Component Inspector

Select the button component on the stage and give it a name in the Properties panel of myButton.

Open the Component Inspector from the Window menu, select the button component on the stage, and set the label to “Learn more!”

Stage

Properties panel

Component Inspector panel
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Moving your design with Flash®

Animating a Component

In order to animate a component, it needs to be inside a symbol. Select the component and choose Convert to Symbol from the Modify menu. Name 
the instance of the movie clip “learnmore” in the properties panel.

Stage

Properties panel
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Moving your design with Flash®

Create a second keyframe for the learnmore button on frame 60. Move the timeline jogger back to frame 50, select the learn more button art on the 
stage and move button down off the stage. Create a motion tween between the two keyframes on the button layer.
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Moving your design with Flash®

learnmore.myButton.useHandCursor = true;
learnmore.myButton.addEventListener(MouseEvent.MOUSE_UP, clickHandler);

function clickHandler(eventObj:MouseEvent):void {
	 navigateToURL(new URLRequest(“http://www.adobe.com/”), “_blank”);
}

 
Using Acrobat Reader’s  
Text selection tool, copy 
and paste the code 
below into the Actions 
panel in Adobe Flash.

Adding ActionScript for a Button Component
Select the 50th frame in the script layer and insert a blank keyframe. Open the Actions panel from the Window menu. Enter the script below.

NOTE:  ActionScript
This is Flash’s internal 
instruction language. 
ActionScript is used 
to tell Flash what to 
do when a user does 
certain things, such as 
“clicking” on a button 
component.

These instructions are 
vital to creating an 
interactive experience 
within Flash file, as well 
as controlling playback; 
such as the stop(); 
action we added back 
on page 24.
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Moving your design with Flash®

Publish Settings
Select File > Publish Settings to access the publish settings for this document. Select both Flash and HTML from the first screen. In the Flash settings 
pane, select Flash Player 9 with ActionSctipt 3.0. In the HTML pane, select Flash Only from the Template menu. When finished, click Publish, then OK.
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Flash created three files in your myAdvertisement folder on your Desktop. promo_ad.swf, promo_ad.html, and AC_RunActiveContent.js*.

To preview the advertisement in a browser, open the promo_ad.html file in a web browser. Click the “Learn more!” at the end of the animation.

* The AC_RunActiveContent.js file is a JavaScript file de-
veloped by Adobe Systems to auto activate flash objects 
when using Internet Explorer in Microsoft Windows.

For more information, please see Preparing your website 
to handle the Microsoft changes to Internet Explorer

http://www.adobe.com/devnet/activecontent/articles/devletter.html
http://www.adobe.com/devnet/activecontent/articles/devletter.html
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Moving your design with Flash®

Setting Flash Security
When running a SWF file from your local computer, Flash Player will warn you if any internet activity is being attempted by a SWF file. Follow the steps 
on the next page to grant security access for any Flash file you are currently working on.

Note: You will not see these security messages when your Flash (.swf) file is on a web server.
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Moving your design with Flash®

Click Settings on the warning dialog box. In the Adobe Flash Player Settings manager, select the Edit locations menu and 
choose the Add location option. Click the Browse for Files button and locate the promo_ad.swf in the myAdvertisement folder 
on the Desktop. Click confirm.

Open the promo_ad.html file again in a web browser and click Reload. Click the “Learn more!” button at the end and you 
should be taken to the website without further warnings.

Choose Add location 
from the Edit locations 
pulldown menu

Click Browse for files to 
locate the promo_ad.swf 
in the myAdvetisement 
folder on your Desktop. 
Click Confirm.

Close the browser 
window, then open 
the promo_ad.html 
file up again in your 
web browser.
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Moving your design with Flash®

Editing Video with Photoshop CS3 Extended
Open the promo_clip.mov QuickTime® movie in Photoshop CS3 Extended.

Photoshop document

Layers panel in Photoshop
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Moving your design with Flash®

Preview video in Photoshop CS3 Extended

Open the Animation panel from the Window menu.

Photoshop document

Animation panel in Photoshop

Move the video jogger to preview 
areas of the video inside of the 
document window.
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Moving your design with Flash®

Make Level and Hue Adjustments to Video

Select the video SmartObject layer and add a Levels Adjustment Layer. Set the Levels to 0 (black), 2.09 (mid-level gray), 227 (white).

Layers panel in Photoshop

Levels adjustment settings 
dialog box

Photoshop document window
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Moving your design with Flash®

Add a Hue/Saturation Adjustment Layer. Set the Hue to -2, the Saturation to +12, and the Lightness to 0.

Layers panel in Photoshop
Hue Saturation adjustment settings dialog box
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Spot Healing a Video

Use the timeline jogger in the Animation panel to locate the 14 second, 25th frame (14:25). With the video SmartObject layer selected, choose the 
Spot Healing tool, click-and-drag to paint spot over the smudge, then release the mouse button. Photoshop Extended will heal the smudge in the 
video exactly the same way it heals a spot in a photograph.

Tools panel in 
Photoshop

Spot Healing 
brush

Locate the smudge 
in the video
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Moving your design with Flash®

There are a total of four frames with a smudge in the sky. Use the Next Frame button in the Animation panel to advance the video one frame at a time; 
then repeat the step of painting over the smudge area with the Spot Healing brush.

Save this file to the myVideo folder on your Desktop as promo_clip.psd.

Animation panel in Photoshop Extended

Use the Next Frame button in the 
Animation panel to advance the 

video one frame at a time.

Spot Healing 
brush

Time = 14:25
Time = 14:26

Time = 14:27
Time = 14:28
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Moving your design with Flash®

Adding Artwork to a Video

Open the video_art.psd file form the assets directory. Shift select the ChristinaCONTENDER, title box, and poster layers in the video_art.psd file and 
drag them to the promo_clip.psd Photoshop file. Make sure the layers appear above the Adjustment layers of the promo_clip.psd file.

video_art.psd file

promo_clip.psd file
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Moving your design with Flash®

Convert Layers in Photoshop to a Smart Object

Select the ChristinaCONTENDER and title box layers and group them into a single SmartObject by right-clicking and selecting Convert to SmartObejct 
from the contextual menu.

Layers panel in Photoshop

Layers panel in Photoshop

Photoshop SmartObject
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Moving your design with Flash®

Adding Animation to Video in Photoshop Extended

In the Animation panel, toggle open the properties for both the ChristinaCONTENDER and poster layers.

Animation panel in 
Photoshop Extended

Animation panel in Photoshop Extended 
with the “ChristinaCONTENDER” and 
“poster” layer properties expanded
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With the timeline jogger on frame 1, select the ChristinaCONTENDER layer, select the Move tool, 
and move the layer down below the bottom edge of the canvas.

christinaCONTENDER layer

Move this layer down below the 
bottom edge of the canvas in 

Photoshop Extended
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Move the timeline jogger to 3:27 and activate the opacity keyframe (click the stopwatch button) on the poster layer. Move the timeline jogger to 4:10 
and set the Opacity for the poster layer in the Layers panel to 0%. Photoshop Extended will automatically create new keyframes when the opacity is 
changed on this layer.

This will keep the poster frame on the screen until 3:37, then it will fully fade out by 4:10, revealing the video below.

Animation panel in Photoshop Extended Animation panel in Photoshop Extended
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Animation panel in Photoshop Extended Animation panel in Photoshop Extended

Move the timeline jogger to 5:00 and activate the position keyframe on the ChristinaCONTENDER layer. Move the timeline jogger to 5:18 and move 
the ChristinaCONTENDER up using the Move tool. Photoshop Extended will automatically create new keyframes when the position is changed on this 
layer.

This will keep the ChristinaCONTENDER below the bottom edge of the canvas until 5:00, then it will move up by 5:18, overlapping the video below.
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Moving your design with Flash®

Move the timeline jogger to 8:28 and activate the position keyframe on the ChristinaCONTENDER layer. Move the timeline jogger to 9:14 and move 
the ChristinaCONTENDER down using the Move tool. Photoshop Extended will automatically create new keyframe when the position is changed on 
this layer.

This will keep the ChristinaCONTENDER up until 8:28, then it will move down by 9:14, revealing the entire video.

Animation panel in Photoshop Extended Animation panel in Photoshop Extended
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Moving your design with Flash®

Rendering Video from Photoshop Extended

Save the document as promo_clip.psd into the myVideo folder.

Choose File > Export > Render Video. Save as a QuickTime® movie (to preserve audio), 
and save the video as promo_clip_revised.mov into the myVideo folder.

Render Video dialog box 
in Photoshop Extended
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Moving your design with Flash®

Using the Adobe Flash CS3 Video Encoder
Adobe Flash CS3 Professional includes a separate application called the Adobe Flash CS3 Video Encoder. This tool is designed to take a 
number of different video file formats and convert them to the Flash Video format. Launch the application then click Add to locate the 
video promo_clip_revised.mov file exported from Photoshop Extended.

Flash Video Encoder CS3 application

Applications folder
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Moving your design with Flash®

Flash Video Encoding Settings

Under the Video pane of the Flash Video Encoding Settings dialog box, choose On2 VP6 as the codec, Medium for quality.

Flash Video Encoding settings: 
Video settings
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Under the Audio pane of the Flash Video Encoding Settings dialog box, set the data rate to 96 kbps (stereo).

Flash Video Encoding settings: 
Audio settings
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Moving your design with Flash®

Under the Crop and Resize pane of the Flash Video Encoding Settings dialog box, set the left and right crop to 16 (resulting in a 400x288 sized video).

Click OK.

Flash Video Encoding settings: 
Crop and Resize settings
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Moving your design with Flash®

Click Start Queue to start the video encoder. The result will be a Flash Video file (FLV) named promo_clip_revised.flv.

Flash Video Encoder CS3 application

The QuickTime® movie is 
encoded and compressed 
into a Flash Video (FLV) file
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Create a Flash Video Player
Create a new Flash File (ActionScript 3.0) file.

Splash screen in Flash

New Flash document
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Drag the promo_clip_revised.flv directly onto the stage of the new Flash file.

Flash document
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Follow the Flash Import Video wizard. Flash will automatically fill in the path to the Flash Video file.

Click Continue.

Import Video wizard in Flash 
Select Video settings
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Moving your design with Flash®

Import Video wizard in Flash 
Deployment settings

Choose Progressive download from a web server. This option will work for any web server.
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Choose a video skin. There are many option for both an “over” and “under” layout in addition to choices for the controls you want to include.

In this example, choose SkinUnderPlaySeekMute.swf. Click Continue.

Import Video wizard in Flash 
Skinning settings: control options
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Choose a color to tint the skin.

Import Video wizard in Flash 
Skinning settings: color setting

Choose a color
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Moving your design with Flash®

Review the summary, then click Finish.

Import Video wizard in Flash 
Summary
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The video object will be laced on the stage with a representation of the chosen video skin. Position the video object in the upper right-hand corner of 
the stage. Resize the stage by clicking the button next to the Size label in the Properties panel and choose 425x340.

Change the stage size 
to 425x340 pixels
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Publish an HTML and Flash file (same as on page 31).

In the myVideo folder you will also see a file named SkinUnderPlaySeekMute.swf. this is an additional SWF 
published by Flash to control the video object. This file is loaded automatically by the promo_clip.swf is run.

Source Flash file

HTML file created 
by Flash

Web-ready SWF 
file referenced by 

the HTML file

myVideo folder

SWF file referenced by 
the video component’s 
skin setting
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Preview in browser

Preview in browser
Open the promo_clip.html file in a web browser to preview the video player.
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learnmore.myButton.useHandCursor = true;
learnmore.myButton.addEventListener(MouseEvent.MOUSE_UP, clickHandler);

function clickHandler(eventObj:MouseEvent):void {
	navigateToURL(new URLRequest("http://www.adobe.com/"), "_blank");
}
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//v1.7
// Flash Player Version Detection
// Detect Client Browser type
// Copyright 2005-2007 Adobe Systems Incorporated.  All rights reserved.
var isIE  = (navigator.appVersion.indexOf("MSIE") != -1) ? true : false;
var isWin = (navigator.appVersion.toLowerCase().indexOf("win") != -1) ? true : false;
var isOpera = (navigator.userAgent.indexOf("Opera") != -1) ? true : false;

function ControlVersion()
{
	var version;
	var axo;
	var e;

	// NOTE : new ActiveXObject(strFoo) throws an exception if strFoo isn't in the registry

	try {
		// version will be set for 7.X or greater players
		axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.7");
		version = axo.GetVariable("$version");
	} catch (e) {
	}

	if (!version)
	{
		try {
			// version will be set for 6.X players only
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.6");
			
			// installed player is some revision of 6.0
			// GetVariable("$version") crashes for versions 6.0.22 through 6.0.29,
			// so we have to be careful. 
			
			// default to the first public version
			version = "WIN 6,0,21,0";

			// throws if AllowScripAccess does not exist (introduced in 6.0r47)		
			axo.AllowScriptAccess = "always";

			// safe to call for 6.0r47 or greater
			version = axo.GetVariable("$version");

		} catch (e) {
		}
	}

	if (!version)
	{
		try {
			// version will be set for 4.X or 5.X player
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.3");
			version = axo.GetVariable("$version");
		} catch (e) {
		}
	}

	if (!version)
	{
		try {
			// version will be set for 3.X player
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.3");
			version = "WIN 3,0,18,0";
		} catch (e) {
		}
	}

	if (!version)
	{
		try {
			// version will be set for 2.X player
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash");
			version = "WIN 2,0,0,11";
		} catch (e) {
			version = -1;
		}
	}
	
	return version;
}

// JavaScript helper required to detect Flash Player PlugIn version information
function GetSwfVer(){
	// NS/Opera version >= 3 check for Flash plugin in plugin array
	var flashVer = -1;
	
	if (navigator.plugins != null && navigator.plugins.length > 0) {
		if (navigator.plugins["Shockwave Flash 2.0"] || navigator.plugins["Shockwave Flash"]) {
			var swVer2 = navigator.plugins["Shockwave Flash 2.0"] ? " 2.0" : "";
			var flashDescription = navigator.plugins["Shockwave Flash" + swVer2].description;
			var descArray = flashDescription.split(" ");
			var tempArrayMajor = descArray[2].split(".");			
			var versionMajor = tempArrayMajor[0];
			var versionMinor = tempArrayMajor[1];
			var versionRevision = descArray[3];
			if (versionRevision == "") {
				versionRevision = descArray[4];
			}
			if (versionRevision[0] == "d") {
				versionRevision = versionRevision.substring(1);
			} else if (versionRevision[0] == "r") {
				versionRevision = versionRevision.substring(1);
				if (versionRevision.indexOf("d") > 0) {
					versionRevision = versionRevision.substring(0, versionRevision.indexOf("d"));
				}
			}
			var flashVer = versionMajor + "." + versionMinor + "." + versionRevision;
		}
	}
	// MSN/WebTV 2.6 supports Flash 4
	else if (navigator.userAgent.toLowerCase().indexOf("webtv/2.6") != -1) flashVer = 4;
	// WebTV 2.5 supports Flash 3
	else if (navigator.userAgent.toLowerCase().indexOf("webtv/2.5") != -1) flashVer = 3;
	// older WebTV supports Flash 2
	else if (navigator.userAgent.toLowerCase().indexOf("webtv") != -1) flashVer = 2;
	else if ( isIE && isWin && !isOpera ) {
		flashVer = ControlVersion();
	}	
	return flashVer;
}

// When called with reqMajorVer, reqMinorVer, reqRevision returns true if that version or greater is available
function DetectFlashVer(reqMajorVer, reqMinorVer, reqRevision)
{
	versionStr = GetSwfVer();
	if (versionStr == -1 ) {
		return false;
	} else if (versionStr != 0) {
		if(isIE && isWin && !isOpera) {
			// Given "WIN 2,0,0,11"
			tempArray         = versionStr.split(" "); 	// ["WIN", "2,0,0,11"]
			tempString        = tempArray[1];			// "2,0,0,11"
			versionArray      = tempString.split(",");	// ['2', '0', '0', '11']
		} else {
			versionArray      = versionStr.split(".");
		}
		var versionMajor      = versionArray[0];
		var versionMinor      = versionArray[1];
		var versionRevision   = versionArray[2];

        	// is the major.revision >= requested major.revision AND the minor version >= requested minor
		if (versionMajor > parseFloat(reqMajorVer)) {
			return true;
		} else if (versionMajor == parseFloat(reqMajorVer)) {
			if (versionMinor > parseFloat(reqMinorVer))
				return true;
			else if (versionMinor == parseFloat(reqMinorVer)) {
				if (versionRevision >= parseFloat(reqRevision))
					return true;
			}
		}
		return false;
	}
}

function AC_AddExtension(src, ext)
{
  if (src.indexOf('?') != -1)
    return src.replace(/\?/, ext+'?'); 
  else
    return src + ext;
}

function AC_Generateobj(objAttrs, params, embedAttrs) 
{ 
  var str = '';
  if (isIE && isWin && !isOpera)
  {
    str += '<object ';
    for (var i in objAttrs)
    {
      str += i + '="' + objAttrs[i] + '" ';
    }
    str += '>';
    for (var i in params)
    {
      str += '<param name="' + i + '" value="' + params[i] + '" /> ';
    }
    str += '</object>';
  }
  else
  {
    str += '<embed ';
    for (var i in embedAttrs)
    {
      str += i + '="' + embedAttrs[i] + '" ';
    }
    str += '> </embed>';
  }

  document.write(str);
}

function AC_FL_RunContent(){
  var ret = 
    AC_GetArgs
    (  arguments, ".swf", "movie", "clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
     , "application/x-shockwave-flash"
    );
  AC_Generateobj(ret.objAttrs, ret.params, ret.embedAttrs);
}

function AC_SW_RunContent(){
  var ret = 
    AC_GetArgs
    (  arguments, ".dcr", "src", "clsid:166B1BCA-3F9C-11CF-8075-444553540000"
     , null
    );
  AC_Generateobj(ret.objAttrs, ret.params, ret.embedAttrs);
}

function AC_GetArgs(args, ext, srcParamName, classid, mimeType){
  var ret = new Object();
  ret.embedAttrs = new Object();
  ret.params = new Object();
  ret.objAttrs = new Object();
  for (var i=0; i < args.length; i=i+2){
    var currArg = args[i].toLowerCase();    

    switch (currArg){	
      case "classid":
        break;
      case "pluginspage":
        ret.embedAttrs[args[i]] = args[i+1];
        break;
      case "src":
      case "movie":	
        args[i+1] = AC_AddExtension(args[i+1], ext);
        ret.embedAttrs["src"] = args[i+1];
        ret.params[srcParamName] = args[i+1];
        break;
      case "onafterupdate":
      case "onbeforeupdate":
      case "onblur":
      case "oncellchange":
      case "onclick":
      case "ondblclick":
      case "ondrag":
      case "ondragend":
      case "ondragenter":
      case "ondragleave":
      case "ondragover":
      case "ondrop":
      case "onfinish":
      case "onfocus":
      case "onhelp":
      case "onmousedown":
      case "onmouseup":
      case "onmouseover":
      case "onmousemove":
      case "onmouseout":
      case "onkeypress":
      case "onkeydown":
      case "onkeyup":
      case "onload":
      case "onlosecapture":
      case "onpropertychange":
      case "onreadystatechange":
      case "onrowsdelete":
      case "onrowenter":
      case "onrowexit":
      case "onrowsinserted":
      case "onstart":
      case "onscroll":
      case "onbeforeeditfocus":
      case "onactivate":
      case "onbeforedeactivate":
      case "ondeactivate":
      case "type":
      case "codebase":
      case "id":
        ret.objAttrs[args[i]] = args[i+1];
        break;
      case "width":
      case "height":
      case "align":
      case "vspace": 
      case "hspace":
      case "class":
      case "title":
      case "accesskey":
      case "name":
      case "tabindex":
        ret.embedAttrs[args[i]] = ret.objAttrs[args[i]] = args[i+1];
        break;
      default:
        ret.embedAttrs[args[i]] = ret.params[args[i]] = args[i+1];
    }
  }
  ret.objAttrs["classid"] = classid;
  if (mimeType) ret.embedAttrs["type"] = mimeType;
  return ret;
}
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//v1.7
// Flash Player Version Detection
// Detect Client Browser type
// Copyright 2005-2007 Adobe Systems Incorporated.  All rights reserved.
var isIE  = (navigator.appVersion.indexOf("MSIE") != -1) ? true : false;
var isWin = (navigator.appVersion.toLowerCase().indexOf("win") != -1) ? true : false;
var isOpera = (navigator.userAgent.indexOf("Opera") != -1) ? true : false;

function ControlVersion()
{
	var version;
	var axo;
	var e;

	// NOTE : new ActiveXObject(strFoo) throws an exception if strFoo isn't in the registry

	try {
		// version will be set for 7.X or greater players
		axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.7");
		version = axo.GetVariable("$version");
	} catch (e) {
	}

	if (!version)
	{
		try {
			// version will be set for 6.X players only
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.6");
			
			// installed player is some revision of 6.0
			// GetVariable("$version") crashes for versions 6.0.22 through 6.0.29,
			// so we have to be careful. 
			
			// default to the first public version
			version = "WIN 6,0,21,0";

			// throws if AllowScripAccess does not exist (introduced in 6.0r47)		
			axo.AllowScriptAccess = "always";

			// safe to call for 6.0r47 or greater
			version = axo.GetVariable("$version");

		} catch (e) {
		}
	}

	if (!version)
	{
		try {
			// version will be set for 4.X or 5.X player
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.3");
			version = axo.GetVariable("$version");
		} catch (e) {
		}
	}

	if (!version)
	{
		try {
			// version will be set for 3.X player
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.3");
			version = "WIN 3,0,18,0";
		} catch (e) {
		}
	}

	if (!version)
	{
		try {
			// version will be set for 2.X player
			axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash");
			version = "WIN 2,0,0,11";
		} catch (e) {
			version = -1;
		}
	}
	
	return version;
}

// JavaScript helper required to detect Flash Player PlugIn version information
function GetSwfVer(){
	// NS/Opera version >= 3 check for Flash plugin in plugin array
	var flashVer = -1;
	
	if (navigator.plugins != null && navigator.plugins.length > 0) {
		if (navigator.plugins["Shockwave Flash 2.0"] || navigator.plugins["Shockwave Flash"]) {
			var swVer2 = navigator.plugins["Shockwave Flash 2.0"] ? " 2.0" : "";
			var flashDescription = navigator.plugins["Shockwave Flash" + swVer2].description;
			var descArray = flashDescription.split(" ");
			var tempArrayMajor = descArray[2].split(".");			
			var versionMajor = tempArrayMajor[0];
			var versionMinor = tempArrayMajor[1];
			var versionRevision = descArray[3];
			if (versionRevision == "") {
				versionRevision = descArray[4];
			}
			if (versionRevision[0] == "d") {
				versionRevision = versionRevision.substring(1);
			} else if (versionRevision[0] == "r") {
				versionRevision = versionRevision.substring(1);
				if (versionRevision.indexOf("d") > 0) {
					versionRevision = versionRevision.substring(0, versionRevision.indexOf("d"));
				}
			}
			var flashVer = versionMajor + "." + versionMinor + "." + versionRevision;
		}
	}
	// MSN/WebTV 2.6 supports Flash 4
	else if (navigator.userAgent.toLowerCase().indexOf("webtv/2.6") != -1) flashVer = 4;
	// WebTV 2.5 supports Flash 3
	else if (navigator.userAgent.toLowerCase().indexOf("webtv/2.5") != -1) flashVer = 3;
	// older WebTV supports Flash 2
	else if (navigator.userAgent.toLowerCase().indexOf("webtv") != -1) flashVer = 2;
	else if ( isIE && isWin && !isOpera ) {
		flashVer = ControlVersion();
	}	
	return flashVer;
}

// When called with reqMajorVer, reqMinorVer, reqRevision returns true if that version or greater is available
function DetectFlashVer(reqMajorVer, reqMinorVer, reqRevision)
{
	versionStr = GetSwfVer();
	if (versionStr == -1 ) {
		return false;
	} else if (versionStr != 0) {
		if(isIE && isWin && !isOpera) {
			// Given "WIN 2,0,0,11"
			tempArray         = versionStr.split(" "); 	// ["WIN", "2,0,0,11"]
			tempString        = tempArray[1];			// "2,0,0,11"
			versionArray      = tempString.split(",");	// ['2', '0', '0', '11']
		} else {
			versionArray      = versionStr.split(".");
		}
		var versionMajor      = versionArray[0];
		var versionMinor      = versionArray[1];
		var versionRevision   = versionArray[2];

        	// is the major.revision >= requested major.revision AND the minor version >= requested minor
		if (versionMajor > parseFloat(reqMajorVer)) {
			return true;
		} else if (versionMajor == parseFloat(reqMajorVer)) {
			if (versionMinor > parseFloat(reqMinorVer))
				return true;
			else if (versionMinor == parseFloat(reqMinorVer)) {
				if (versionRevision >= parseFloat(reqRevision))
					return true;
			}
		}
		return false;
	}
}

function AC_AddExtension(src, ext)
{
  if (src.indexOf('?') != -1)
    return src.replace(/\?/, ext+'?'); 
  else
    return src + ext;
}

function AC_Generateobj(objAttrs, params, embedAttrs) 
{ 
  var str = '';
  if (isIE && isWin && !isOpera)
  {
    str += '<object ';
    for (var i in objAttrs)
    {
      str += i + '="' + objAttrs[i] + '" ';
    }
    str += '>';
    for (var i in params)
    {
      str += '<param name="' + i + '" value="' + params[i] + '" /> ';
    }
    str += '</object>';
  }
  else
  {
    str += '<embed ';
    for (var i in embedAttrs)
    {
      str += i + '="' + embedAttrs[i] + '" ';
    }
    str += '> </embed>';
  }

  document.write(str);
}

function AC_FL_RunContent(){
  var ret = 
    AC_GetArgs
    (  arguments, ".swf", "movie", "clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
     , "application/x-shockwave-flash"
    );
  AC_Generateobj(ret.objAttrs, ret.params, ret.embedAttrs);
}

function AC_SW_RunContent(){
  var ret = 
    AC_GetArgs
    (  arguments, ".dcr", "src", "clsid:166B1BCA-3F9C-11CF-8075-444553540000"
     , null
    );
  AC_Generateobj(ret.objAttrs, ret.params, ret.embedAttrs);
}

function AC_GetArgs(args, ext, srcParamName, classid, mimeType){
  var ret = new Object();
  ret.embedAttrs = new Object();
  ret.params = new Object();
  ret.objAttrs = new Object();
  for (var i=0; i < args.length; i=i+2){
    var currArg = args[i].toLowerCase();    

    switch (currArg){	
      case "classid":
        break;
      case "pluginspage":
        ret.embedAttrs[args[i]] = args[i+1];
        break;
      case "src":
      case "movie":	
        args[i+1] = AC_AddExtension(args[i+1], ext);
        ret.embedAttrs["src"] = args[i+1];
        ret.params[srcParamName] = args[i+1];
        break;
      case "onafterupdate":
      case "onbeforeupdate":
      case "onblur":
      case "oncellchange":
      case "onclick":
      case "ondblclick":
      case "ondrag":
      case "ondragend":
      case "ondragenter":
      case "ondragleave":
      case "ondragover":
      case "ondrop":
      case "onfinish":
      case "onfocus":
      case "onhelp":
      case "onmousedown":
      case "onmouseup":
      case "onmouseover":
      case "onmousemove":
      case "onmouseout":
      case "onkeypress":
      case "onkeydown":
      case "onkeyup":
      case "onload":
      case "onlosecapture":
      case "onpropertychange":
      case "onreadystatechange":
      case "onrowsdelete":
      case "onrowenter":
      case "onrowexit":
      case "onrowsinserted":
      case "onstart":
      case "onscroll":
      case "onbeforeeditfocus":
      case "onactivate":
      case "onbeforedeactivate":
      case "ondeactivate":
      case "type":
      case "codebase":
      case "id":
        ret.objAttrs[args[i]] = args[i+1];
        break;
      case "width":
      case "height":
      case "align":
      case "vspace": 
      case "hspace":
      case "class":
      case "title":
      case "accesskey":
      case "name":
      case "tabindex":
        ret.embedAttrs[args[i]] = ret.objAttrs[args[i]] = args[i+1];
        break;
      default:
        ret.embedAttrs[args[i]] = ret.params[args[i]] = args[i+1];
    }
  }
  ret.objAttrs["classid"] = classid;
  if (mimeType) ret.embedAttrs["type"] = mimeType;
  return ret;
}
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